Installation error my internet is not slow

Arguments:
C:\Program Files\nodejs\node.exe C:\Users\alouk\AppData\Roaming\npm\node_modules\yarn\bin\yarn.js install --production --no-optional --network-timeout 1000000

PATH:
C:\Users\alouk\AppData\Local\npm-cache_npx\2d56dd13733e9da7\node_modules.bin;D:\ecommerce web\node_modules.bin;D:\node_modules.bin;C:\Users\alouk\AppData\Roaming\npm\node_modules\npm\node_modules@npmcli\run-script\lib\node-gyp-bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\Windows\System32\OpenSSH;C:\Program Files\Git\cmd;C:\Program Files\nodejs;C:\Users\alouk\AppData\Local\Microsoft\WindowsApps;C:\Users\alouk\AppData\Local\Programs\Microsoft VS Code\bin;C:\Users\alouk\AppData\Roaming\npm;C:\adb;C:\Users\alouk\AppData\Local\Microsoft\WindowsApps;;C:\Users\alouk\AppData\Local\Programs\Microsoft VS Code\bin;C:\Users\alouk\AppData\Roaming\npm

Yarn version:
1.22.19

Node version:
18.18.0

Platform:
win32 x64

Trace:
Error: https://registry.yarnpkg.com/date-fns/-/date-fns-2.30.0.tgz: ESOCKETTIMEDOUT
at ClientRequest. (C:\Users\alouk\AppData\Roaming\npm\node_modules\yarn\lib\cli.js:141517:19)
at Object.onceWrapper (node:events:631:28)
at ClientRequest.emit (node:events:517:28)
at TLSSocket.emitRequestTimeout (node:_http_client:847:9)
at Object.onceWrapper (node:events:631:28)
at TLSSocket.emit (node:events:529:35)
at Socket._onTimeout (node:net:598:8)
at listOnTimeout (node:internal/timers:569:17)
at process.processTimers (node:internal/timers:512:7)

npm manifest:
{
“name”: “notagain”,
“private”: true,
“version”: “0.1.0”,
“description”: “A Strapi application”,
“scripts”: {
“develop”: “strapi develop”,
“start”: “strapi start”,
“build”: “strapi build”,
“strapi”: “strapi”
},
“devDependencies”: {},
“dependencies”: {
@strapi/strapi”: “4.15.4”,
@strapi/plugin-users-permissions”: “4.15.4”,
@strapi/plugin-i18n”: “4.15.4”,
@strapi/plugin-cloud”: “4.15.4”,
“better-sqlite3”: “8.6.0”,
“react”: “^18.0.0”,
“react-dom”: “^18.0.0”,
“react-router-dom”: “5.3.4”,
“styled-components”: “5.3.3”
},
“author”: {
“name”: “A Strapi developer”
},
“strapi”: {
“uuid”: “a338c677-c504-41b4-8e5f-a8ef42c6c5f2”
},
“engines”: {
“node”: “>=18.0.0 <=20.x.x”,
“npm”: “>=6.0.0”
},
“license”: “MIT”
}

yarn manifest:
No manifest

Lockfile:
No lockfile