Issue transfering data from strapi-cloud to local instance versions incompatible

System Information
  • Strapi Version: 4.10.6 (strapi-cloud) and 4.14.2 (strapi-local)
  • Operating System: osx
  • Database: default
  • Node Version: v20.2.0
  • NPM Version: 9.6.6
  • Yarn Version: 1.22.19

I would like to make a local backup of our strapi cloud environment to restore it eventually in a new strapi-cloud project. Our current strapi-cloud project is working (have access to admin console) but disconnected to our GitHub account.

I installed a fresh local version (4.14.2) and then from this folder I ran;
yarn strapi transfer --from

and then I got an error: “error: [FATAL] The source and destination provide are targeting incompatible Strapi versions (using the “exact” strategy). The source (source::remote-strapi) version is 4.10.6 and the destination (destination::local-strapi) version is 4.14.2”

I tried to install an older version of strapi locally, with;
yarn create strapi-app@v4.10.6

when also adjusting the node version (back to 18.18.0) it strands (command failed)

success Installed "create-strapi-app@4.10.6" with binaries:
      - create-strapi-app
/bin/sh: /usr/local/bin/create-strapi-app@v4.10.6: No such file or directory
error Command failed.

What steps do you think will work to transfer from the old version of our strapi-cloud to a local environment?

It looks like we managed to resolve this now. The yarn command-line was failing. When we replaced it with the npx create-strapi-app ... it was working fine for us.