Naming convention for Single types, Collections and fields

System Information
  • Strapi Version:
  • Operating System:
  • Database:
  • Node Version:
  • NPM Version:
  • Yarn Version:

Hello strapi community,

I would like to hear recommendations about the naming of Single types and Collections. Are there any official conventions?

The naming of fields is also of interest. There is a little confusion with them. Some of the default fields are written in the next style example_field, while others are in camelcase exampleField. For example, the fields of the picture are given.
When creating your own fields, which of the naming should be preferred?
previewUrl and provider_metadata as example


Also curious if there is a preferred convention for this. Anyone?

Hello there!

If whatever naming convention you use does not return any errors.
It really depends on your preferences :slight_smile: