New Documentation release: Strapi v4.3.0

Hello everyone! :wave:
Here’s everything new in this week’s documentation deployment:

New :tada:

  • We’ve added complete Media Library documentation to the User Guide, including how to use the all-new Folders feature.
  • We’ve added TypeScript instructions to the Developer Documentation and updated code block examples throughout the documentation to include both a JavaScript and a TypeScript version.

Improvements :sparkles:

3 Likes

Hello,
i’ve updated strapi from 4.2.3 → 4.3.0.
And have this situation:

Have to do some migration guide? ìI can’t find and from the error i can’t understand where is broken.

This is my package.json

"dependencies": {
    "@exfabrica/strapi-plugin-awesome-help": "^1.0.8",
    "@notum-cz/strapi-plugin-content-versioning": "^0.4.3",
    "@strapi/plugin-graphql": "4.3.0",
    "@strapi/plugin-i18n": "4.3.0",
    "@strapi/plugin-seo": "^1.7.4",
    "@strapi/plugin-users-permissions": "4.3.0",
    "@strapi/provider-email-nodemailer": "^4.3.0",
    "@strapi/provider-upload-local": "^4.3.0",
    "@strapi/strapi": "4.3.0",
    "better-sqlite3": "7.6.2",
    "lodash.set": "^4.3.2",
    "mime-types": "^2.1.27",
    "patch-package": "^6.4.7",
    "pg": "^8.7.3",
    "pg-connection-string": "^2.5.0",
    "postinstall-postinstall": "^2.1.0",
    "strapi-code-themes": "^1.0.1",
    "strapi-plugin-config-sync": "^1.0.2",
    "strapi-plugin-duplicate-button": "^1.0.4",
    "strapi-plugin-entity-relationship-chart": "^4.1.0",
    "strapi-plugin-ezforms": "^0.0.7",
    "strapi-plugin-import-export-entries": "^1.6.9",
    "strapi-plugin-local-image-sharp": "^1.2.0",
    "strapi-plugin-measurement-protocol": "^1.0.1",
    "strapi-plugin-menus": "^1.0.0",
    "strapi-plugin-notes": "^1.0.1",
    "strapi-plugin-publisher": "^1.1.3",
    "strapi-plugin-sitemap": "^2.0.8",
    "strapi-plugin-slugify": "^2.2.2",
    "strapi-plugin-wysiwsg-react-md-editor": "^4.2.0",
    "strapi-stripe": "^2.1.4",
    "strapi-tiptap-editor": "^0.7.14"
  },
  "engines": {
    "node": ">=12.x.x <=16.x.x",
    "npm": ">=6.0.0"
  },

Hello @cmdc_business. I’m sorry you’re having trouble. I’m not sure, but it looks like the error is related to the strapi-stripe plugin. This is a 3rd party plugin. Do you know if it was already updated to work with Strapi v4.3.0?

By the way, if there is no migration guide for a minor version (4.x) it’s because it does not introduce breaking changes (as mentioned at the top of our Migration Guides page). In that case you should follow the Update Strapi guide.

If the issue persists, I’d encourage you to check the GitHub issues on the strapi/strapi repo and create a new one if necessary, so our Support team can help you. :hugs:
Is there something else I can help you with regarding the TypeScript or Media Library documentation? :blush:

1 Like

Hello @cmdc_business,
we have fixed this error, please install the latest version of strapi-stripe here.
Thanks.

2 Likes

Thank you very much for your work on this plugin and for helping the community, @Nishekh_ER! :hugs:

2 Likes