New locale can't be fetched by API

System Information
  • Strapi Version: 4.11.5
  • Operating System: ubuntu 22.04
  • Database: sqlite
  • Node Version: 18.15
  • NPM Version: 9.5
  • Yarn Version: 1.22.19

Hi I’m using the internationalization plugin with 2 languages. Everything was fine until I added the third language from the Admin panel. In the Admin panel, everything works fine, I can add the language, and I can switch languages in Single type or Collection type and update the field in different languages.

But when I tried to fetch data using Postman, I can’t get the data of the new language, only the two only ones. I tried “?populate=%2A”, “?locale=all”, “?locale=zh-CN” (new language, not found error). The original two still work perfectly ("?locale=en" & “?locale=zh-Hant-HK”), just can’t get the new one.

I also tried to re-build strapi, tried the dev mode and production mode, still no luck.

How can I fix this?

I figured that the new language can’t be published. When I switch to the new language, it shows on the top right that it’s a draft and the Publish button is available instead of the Unpublish. The other two languages are published for this Single type. But when I click the Publish button and I got a “Warning: already published” and it can’t be published. How do I fix this?