New release: Strapi v3.1.6 is live

Hi everyone!

We have released a new version (v3.1.6) with several enhancements and bug fixes.
Improving small details that matter :muscle:

See more info about the release in the changelog https://github.com/strapi/strapi/releases/tag/v3.1.6

Stay tuned for more updates!

7 Likes

Wooo \o/ love bug fixes

Hello,

I just tried to upgrade from 3.1.5 to 3.1.6 following the guide but it failed rebuilding the admin, a file was missing:
/srv/app/.cache/admin/src/containers/Webhooks/EditView/utils/formatData.js’

Upgrading last week from 3.1.4 to 3.1.5 was fine with this procedure

Odd since you are in docker :thinking: Can you ensure you wipe out the .cache and build folders as well as either package-lock.json and yarn.lock? I’m wondering if there was a package cache issue.

On that note I created a nice little shell script to update etc if you are using docker
Make sure you update package.json before running this script.
This will assume your docker-compose using name of strapi
Just save as update.sh then give execute permissions
chmod +x update.sh

#!/bin/bash

echo "Executing order 66"
docker-compose down &> /dev/null &&
rm -rf data/
rm -rf app/node_modules/
rm -rf app/.cache/
rm -rf app/build/
cho "Order 66 have been executed commander"
tput setaf 2; echo "All your base are belong to us"
echo "Upgrading systems"
docker-compose run strapi yarn install --silent &&
docker-compose run strapi yarn build --clean &&
echo "System upgrade complete commander"
echo "Starting all systems"
docker-compose up -d
tput setaf 2; echo "All system are go and green, ready for your control commander at http:/localhost/admin"
2 Likes

First time I already did the cleanup before launching the upgrade
I just tried again and it also failed, but with a different missing file.

But this time I can load the admin page http://localhost:1337/admin/

:laughing:

1 Like

It feels like there is something odd going on with your node_modules as I’ve seen this before and I don’t remember exactly how this was solved, when you cleaned stuff up did you wipe your node_modules (I know I didn’t mention it before, but usually yarn will do it anyway if you don’t have a yarn.lock).

On a side note, I assume your docker container is saving the project to disk in a persistent way?

Before trying the wipe of node_modules I launched again the “yarn build” and it ended successfuly :stuck_out_tongue:

PS : yes my docker container is saving the project to disk in a persistent way

image

:laughing: Well I’m glad you got it working (Ghost in the machine :stuck_out_tongue: )

2 Likes