Npm ERR! network This is a problem related to network connectivity. My terminal keeps throwing me this error

npm timing metavuln:calculate:security-advisory:sqlite3:TV0u8kXay+ITFmCEoZQcEvDbxzHVA4SDtNszU04uUI+ZVGVSksJmtWMxgENlV+v27Cu0qjWsZffbd+X+l/UiCQ== Completed in 52ms
npm timing metavuln:cache:get:security-advisory:strapi-provider-upload-local:tEz11+YE22fs0UzZO/06HSfzT1kKfBOCJ1WrfwoiKf0MiXECpZu31E6qqpn3cbq48ZP+wqYnUmcJeTOeSuJ3XQ== Completed in 2ms
npm http fetch GET 200 14335ms (cache miss)
npm timing reifyNode:node_modules/strapi-admin Completed in 14522ms
npm timing reify:rollback:createSparse Completed in 764ms
npm timing reify:rollback:retireShallow Completed in 46ms
npm timing command:install Completed in 41843ms
npm ERR! network Socket timeout
npm ERR! network This is a problem related to network connectivity.
npm ERR! network In most cases you are behind a proxy or have bad network settings.
npm ERR! network
npm ERR! network If you are behind a proxy, please make sure that the
npm ERR! network ‘proxy’ config is set properly. See: ‘npm help config’
npm timing npm Completed in 42068ms

npm ERR! A complete log of this run can be found in:
npm ERR! /home/animu5/.npm/_logs/2022-08-13T18_03_17_219Z-debug-0.log

Welcome to the Strapi Community @Mr_hacker :wave: :waffle:

Are you behind a proxy by any chance ?

You can also try

npm config set fetch-timeout 60000

To set the timeout if using npm 6 then you can use

npm config fetch-retry-maxtimeout 60000

Hi I’m facing exact error while installing npm packages… I’ve tried every solution but I’m still getting the same error

Are you behind a corporate proxy ?
Also are you using yarn or npm