Npm run develop not found

strapi version 3.1.0-alpha.5
npm version 7.16.0
node v14.16.1

Hello I currently have a project that I created from ubuntu 20.04 but I have not been able to run it when I run npm run develop it doesn’t run but I don’t get an error I tried it on a windows computer and it runs but not in ubuntu.

Try running the following command.

strapi develop

Or simply access your package.json file and map the command ‘strapi develop’ to the npm command ‘develop’, like so.

    "scripts": {
        "develop": "strapi develop -- --watch-admin --clean",
        "start": "strapi start",
        "build": "strapi build",
        "strapi": "strapi",

Hello sorry for responding so late in the end I could not solve it and then try to try it that way and also did not work I do not know what it is but I could not solve it in ubuntu

You shouldn’t be using this version, any of the alphas will almost certainly be broken badly. The current version is v3.6.6

Also your npm version should v6, not v7. We won’t support Node 16/NPM v7 until the upcoming Strapi v4 release.

The npm run develop or yarn develop is assuming you sitting in the root directory of the Strapi project as it’s just a short code to run a script from the package.json:

"scripts": {
    "develop": "strapi develop",
    "start": "strapi start",
    "build": "strapi build",
    "strapi": "strapi"