Publish: Warning: Not Found

System Information
  • Strapi Version: 4.12.1
  • Operating System: Mac Ventura
  • Database: SQL Lite
  • Node Version: 16.20.1
  • NPM Version:
  • Yarn Version: 1.22.19

I created a new Single Type named Alert with the following fields:

  1. alert: Text
  2. url: text
  3. visible: Boolean (default to false and required)

When I go to Content Manager > Single Types > Alert as a Super Admin, add an alert, url, and check visible to TRUE, I can click Save and everything looks good. When I click Publish, I receive the error “Warning: Not Found”. If i check the Console > Network > Fetch/XHR, there is a 404 Not Found error for the numberOfDraftRelations request.


“data”: null,
“error”: {
“status”: 404,
“name”: “NotFoundError”,
“message”: “Not Found”,
“details”: {}


I have the same issue.

Same. Running current version 4.12.1

Downgrading to v4.11.1 fixed it for me.

1 Like

Same for me. Downgrading to 4.11.7 worked for me.


Strapi v 4.12.5. I have the same situation with a collection. When publishing an item, an error is thrown. Downgrading the version to 4.11.7 solves the problem.

I was seeing the same issue, but when I removed the build and .cache directories from my Strapi instance and re-ran the build script I can now publish content types using 4.12.5


Thank you ! Removing .cache and dist file solved the issue for me.

Same problem here.

Same issue.
After I upgrade strapi from 4.11.7 to version 4.12.7 and this publish error occur.
Here is the fix:
remove build and .cache folders, rebuild the project npm run build and then the error gone.

I am still facing the same issue with version 4.13.5. As suggested I removed .cache and build folders and built again but the problem persists.

upgrading to 4.13.6 and building again by removing .cache and build seems to have resolved the issue.

1 Like

Downgrading to v4.11.1 fixes the issue, but you will have the same problem every time you want to upgrade.

@Sawa 's answer fixed it for me. The build part.