Request for assistance with importing data into Strapi Cloud database from an existing database

Hello, previously I utilized the complimentary version of Strapi which was hosted on GCP. However, due to the high billing from GCP, I have recently transitioned to Strapi Cloud. After linking Strapi Cloud with my GitHub account, I have noticed that all of my data is missing. I suspect that Strapi Cloud operates with its own database, and I have been unable to locate any relevant documentation on how to populate data in Strapi SQL. Can someone assist me in understanding how to import data from my existing database into the Strapi Cloud database?


1 Like

The transfer process has been successfully completed!

I was able to bypass the integrity check by commenting out the line in Local Strapi, and it worked.

await this.integrityCheck()

According to Strapi, a formal solution has been acknowledged and is expected to be released with their upcoming update slated for April 12th.

Thank you, I attempted to use data-transfer but encountered a schema mismatch due to the presence of logging feature on the strapi cloud. I had to hardcode a solution by bypassing the integrity check and directly uploading the data to the cloud. Nevertheless, thank you for responding.

I also tried the data transfer method but it didn’t work because of the schema differences. I tried to force it but it fails due to a websocket error which is mentioned here (Data transfer transfer websocket connection dies due to memory leak · Issue #17749 · strapi/strapi · GitHub)

I’m now trying to use a pg_dump script which has worked locally for me but hasn’t quite worked on Strapi cloud. Does anyone know what the schema of the Strapi cloud db should be?
Mine currently exists as public

If you update both the cloud and the local instance of strapi to 0.0.0-experimental.c594d39bd99186eab7f05bd9517adc6704d3b1a2 data transfer will work but would be slow see the issue you provided yourself.

Thanks for replying. I got an error saying Review workflows feature does not exist on source using the Strapi transfer feature.

Do you potentially have suggestions?

Dubble checked that should be a warning you can ignore. If you ignore it it will start doing the data transfer it will be very slow doing so do.

I see, that’s good to know. I have some other issues I need to resolve as we subscribe to one of the db lifecycles. It seems that the method strapi.requestContext is undefined.

I get the error [FATAL] restore failed TypeError: Cannot destructure property 'request' of 'strapi.requestContext.get(...)' as it is undefined.

Regardless, thanks again, this has been very helpful! :slight_smile: