Strapi App content-type-builder page returns empty screen

My strapi app in Localhost (http://localhost:1337/admin/plugins/content-type-builder/content-types/ returns an empty screen, and I’m not able to access the content type builder page or the content manager page section. I tried downgrading the Strapi version as per other community posts, but no luck. Please someone help me to sort out this issue. I’ve faced this error multiple times, so I have to start from scratch.

This is probably an issue with your setup of strapi, I would require more information to sort this out.

can you provide the following info:

version of strapi:
version of node:
package manager (npm/yarn):
plugins used:
other modifications done:

Thanks a lot for your response.

Please find below the required details.

“dependencies”: {
@ckeditor/strapi-plugin-ckeditor”: “^0.0.10”,
@strapi/plugin-i18n”: “4.13.1”,
@strapi/plugin-seo”: “^1.8.0”,
@strapi/plugin-users-permissions”: “4.13.1”,
@strapi/strapi”: “4.13.1”,
“better-sqlite3”: “7.4.6”,
“react”: “^18.0.0”,
“react-dom”: “^18.0.0”,
“react-router-dom”: “^5.2.0”,
“sharp”: “^0.33.0”,
“strapi-tiptap-editor”: “^0.9.12”,
“styled-components”: “^5.2.1”

  1. I created a collection type “page” in contnet-type-builder, and due to some reasons, I modified the name in the React frontend or deleted it from content-type-builder. I was then not able to access the collection-type “page” in any way.

  2. In content manager, collection-type “page” keeps loading with no other action after that, but I can access other collection types.

  3. When I try to access content-type-builder “page” collection-type, it redirects to an empty page to above mentioned URL.

I’m completely stuck there and not able to proceed further, so I used to start the project from scratch and end up with the same issue. It’s totally frustrating.

Note: In the beginning i was using strapi 4.13.7 version, after this issue I downgraded it to 14.3.1 but no luck.

I think I’m having the same issue, and it’s occurred on two different Strapi sites I’ve worked on, so I don’t think it’s site specific. When try to create a content type called “Page”, it just goes to a blank white screen. No schema files get updated in the Strapi source.

Hello there! I have the same problem and I think that i18n is to blame here. Because I get it after installing yarn add @strapi/plugin-i18n. I’ve also tried yarn add @strapi/plugin-i18n@4.10.4. So v4.24.3 gives me a blank screen on the http://localhost:1337/admin/, but the v4.10.4 lets me go into the admin panel and do whatever I want before I going to the content manager http://localhost:1337/admin/content-manager/, than just a blank screen with such errors: