Strapi Cloud and v4.7 with Data Transfer & Audit logs updates release

Hello everyone!
Big news - Strapi Cloud is live :clap:

Strapi Cloud provides more value than just hosting, it also includes out of the box features and capabilities such as easy deployment, database storage, email provider, global CDN, real-time logs, email / in-app notifications and advanced CMS features.

Read the Strapi Cloud announcement blog post to learn more and join the Community Call today at 5PM CET / 8AM PDT :hugs:

We’ve also released v4.7 with the Data Transfer feature and Audit Logs improvements, and made changes to the Enterprise pricing:

Please let us know what you think about the updates and stay tuned for the next releases!

What is ‘the data transfer feature’ exactly ?

next Diets iteration.

You can now pull all data from 1 strapi instance to an other see

is this different from a db table clone ? what about the seeds/salts in the env var file?

Hello, thanks for this new feature.
I tried it at once. Here are my first impressions.

Local to Local is ok

I created two local apps one on 1337 and anther on 1339. They use sqlite and are pretty simple, but they have already custom types, components, users…

  • I create a transfer token on the target env. 1339 : OK
  • Then I use the transfer token and do a yarn strapi transfer --to http://localhost:1339/admin --to-token be4185... in the source env 1337.
  • I get a detailed feedback and a Transfer process has been completed successfully!

Local to Cloud ??

Now I did exactly the same thing (same repository) from Local to Cloud.

  • I create a transfer token on the cloud env : OK
  • Then I use this and do a yarn strapi transfer --to --to-token xdr345... in the source env 1337.
  • Then I get an error:
    Starting transfer...
    [2023-03-07 17:21:59.711] error: [FATAL] Unexpected server response: 404
    Transfer process failed.
    error Command failed with exit code 1.

There is not enough information to fix that.
The runtime log says : GET /admin//transfer/runner/connect (3 ms) 404. (that is a NOT FOUND, but why??)

It would be nice to have more error logs on that, because I have no way to transfer data otherwise.

Thanks for you help


I had the exact same error and I figured out that it was because I was not including /admin in the final destination URL. Hope this can help anyone who had the same error has me that doesn’t explain it.