Strapi Import Error: '@strapi/permissions' does not contain a default export

System Information
  • Strapi Version^4.17.1:
  • **Operating Systemmac os Monterey (12.7.4):
  • **Databasepostgres:
  • **Node Versionv20.12.0:
  • **NPM Version10.5.0:

I’m encountering an import error while working with Strapi. When attempting to import the ‘@strapi/permissions’ module in my project, specifically in the engine.mjs file located at ./Strapi Backends/grocery-admin/node_modules/@strapi/strapi/dist/services/content-api/permissions/engine.mjs`, I receive the following error message:

Attempted import error: ‘@strapi/permissions’ does not contain a default export (imported as ‘permissions’).

I am new to Strapi and am unsure how to resolve this issue. How to correctly import the ‘@strapi/permissions’ module?

I tried importing the module using the following syntax:

import permissions from '@strapi/permissions';

I expected this import statement to work as intended, allowing me to use the ‘@strapi/permissions’ module in my code. I have also tried importing the module without assigning it to a variable (import ‘@strapi/permissions’;), but that did not resolve the issue either.