Strapi installation is stuck on 'installing dependencies'

System Information
  • Strapi Version: latest
  • Operating System: Windows 10
  • Node Version: 16.13.0
  • NPM Version: 7.21.1

I am completely stuck on ‘installing dependencies’ (1 hour thus far) after running ‘npx create-strapi-app@latest’ in both VS Code terminal (bash) and with node.js command prompt.

The issue is now resolved. I updated node.js to version 16.13.1 and npm to version 8.3.0 and now I can install the dependencies.

1 Like

Follow up error, I still can’t start the development server. This is a copy from my terminal:

Creating files.
Dependencies installed successfully.

Your application was created at…

backend@0.1.0 build
strapi build “–no-optimization”

Building your admin UI with development configuration …

  • Webpack █████████████████████████ building (61%) 1/1 entries 130/140
    dependencies 33/94 modules 61 active

ModuleNotFoundError: Module not found: Error: Can’t resolve ‘@strapi/design-system/themes’ in ‘D:\Documents\Web Development\Courses\Strapi Crash Course with React and GraphQL\reviews-app\backend.cache\admin\src’…

Resolved the second issue by running:

npm install @strapi/design-system

Thanks, I solved the first problem, now I have this one.

Do you know how to solve it?

I had same problem, and I talked to @DMehaffy about it and he told me that they know about the problem and for now node >= 16 isn’t supported. Strapi will solve this soon.


it’s supported in v4 but not v3.

For v4 we know the reason I believe and temp workaround is downgrade to node 14 or install yarn globally.

It’s primarily because npm 8 is crazy about dependencies whereas yarn doesn’t care…

I had same issue with my project and I solved by downgrading the npm to v7.24.2, maybe the same will be available for v4. The npm v8.0 is in fact some alfa version, they stripped out programmatic api.

I made this installations…

npm install @strapi/desingn-system
npm install --save-dev webpack
npm install util
npm install assert
npm install --save-dev process

When the terminal showed me errors, it showed me the modules missing…
Now is running.

1 Like

Hello there, I just wanted to add to this post. I had this same problem and was able to resolve it by updating NPM using this command: npm install -g npm@latest. Hope this helps!

1 year later and still the same issue (windows 11 & visual code, npm 9.2.0)
Impossible to install with : npx create-strapi-app@latest my-project
Error log : impossible to install dependencies etc…