Strapi local host is not starting after installing graphql

  • Strapi Version:
  • Operating System:
    Chrome OS
  • Database:
  • Node Version:
  • NPM Version:

I am creating a blog with strapi and astro. I just wanted to use graphql for my project. After I installed graphql to my strapi directory and when try to do “npm run develop” it gives me an error. The error is given below.

“Error: Cannot use GraphQLScalarType “Time” from another module or realm.”

Please help me to solve this problem. I tried below things,

  • Checking duplicate dependencies.
  • Remove node modules and npm install.
  • Remove package.json graphql and adding again.
  • Adding resources in the package.json.
  • Clear npm cache.

Any of these didn’t solve this error.

Just tested GraphQl Plugin from the market store and it worked.

I installed it via

 yarn add @strapi/plugin-graphql

restarted Strapi app. When navigate to http://localhost:1337/graphql

I get the following screen.

@Nomishka look at this issue

1 Like

Thank you for sharing the link.

1 Like