Strapi not uploading to Cloudinary

I’ve installed the last Cloudinary provider (@strapi/provider-upload-cloudinary) and did the configuration as the doc said, but the files still uploads locally. This happens both in production and development mode.

If anyone could help me in this issue, this is the repository: GitHub - johnnycfg/strapi-imob-system

1 Like

For anyone facing the same problem, I fixed it changing the plugins file extension. I’m using typescript in my project and when I created the plugin file, it was with .js extension. After some hours looking into the strapi core (and putting some console.log haha) and trying to see witch config were being returned, I changed the extension to .ts for a last test and it works.

1 Like

absolute legend, finally found the answer after reading a million forum threads and checking and rechecking my config :smiley:

1 Like

Hello, it worked for few image uploads to Cloudinary yesterday.
Today after I restarted Strapi and tried uploading, I found my images are all going to localhost and not to Cloudinary.

Is it still working for you?