Strapi Starter - Error on Installing Front-end Dependencies

System Information
  • Strapi Version: not indicated (assumed to be 4)
  • Operating System: Windows 1
  • Database: sqlite
  • Node Version: 14.7.6
  • NPM Version: 8.3.0
  • Yarn Version: N/A

Just started evaluating Strapi…

Getting numerous “cannot resolve dependency errors” when installing Strapi Starter:

  • npx create-strapi-starter my-project next-blog
  • quickstart option
  • errors as noted below
  • install then hangs

Any suggestions?

  • Is this install stable?


Error Log (partial)
54 verbose cwd I:\apps\sandbox\my-project\frontend
55 verbose Windows_NT 10.0.19043
56 verbose argv “D:\PROGRAMS-DEV-LANG-JS\NODE-14.17.06\node.exe” “C:\Users\my-name\AppData\Roaming\npm\node_modules\npm\bin\npm-cli.js” “install”
57 verbose node v14.17.6
58 verbose npm v8.3.0
59 error code ERESOLVE
60 error ERESOLVE unable to resolve dependency tree
61 error
62 error While resolving: my-next-blog@1.0.0
62 error Found: react@17.0.0
62 error node_modules/react
62 error react@“17.0.0” from the root project
62 error
62 error Could not resolve dependency:
62 error peer react@"^17.0.2" from next@11.1.3
62 error node_modules/next
62 error next@"^11.0.0" from the root project
62 error peer next@">=10.2.0" from eslint-config-next@11.1.3
62 error node_modules/eslint-config-next
62 error dev eslint-config-next@"^11.0.1" from the root project
62 error
62 error Fix the upstream dependency conflict, or retry
62 error this command with --force, or --legacy-peer-deps
62 error to accept an incorrect (and potentially broken) dependency resolution.

I just reviewed the change log and see that V4 just went live on 2021.11.30, so I’m guessing this is just a case of the starter scripts needing to be tweaked for V4.

The create-strapi-app script has a minor issue (@strapi/design-system needs to be installed manually), but other than that, everything seems to be working fine!

I’m going to flag this closed on the assumption that the starter scripts will get updated soon enough.

1 Like

Is this issue resolved? I just had the same problem 8 months later.

I can manually install the frontend project by using --legacy-peer-deps but because the automated installation doesn’t complete, I don’t know if there are any other installation steps necessary