Strapi v4.10.1 removes responsive images

System Information
  • Strapi Version: 4.10.1
  • Operating System: macOS, Docker
  • Database: sqlite, postgres
  • Node Version: 18
  • NPM Version:
  • Yarn Version:


on some deployments in our docker environment, Strapi removes the generated responsive images. The original files remain available, but the generated versions are removed. I did not change any default settings. We are uploading the files via the AWS S3 provider to a bucket on Scaleway.

This happens to images uploaded via the REST API, but not with the images uploaded via the admin panel. I also recognize, that on these images, which were deleted from our buckets, the mime-type was wrong (it was DOC). We fixed this, maybe this was the problem.

Do you have any ideas?


Seems to be a problem with the config-sync plugin. It tells the production strapi which ID it should use for the API Uploads directory, but the production backend itself has a different id, which is why it always creates a new directory. We keep on investigating the problem.

Hi @n2o,

I’ve allready replied on the other issue you’ve created on the Forums regarding the config sync plugin.
Though for this issue I’m not too certain. I’m not familiar with the responsive images plugin so I can’t really help here.

Do let me know if you find the source of the issue and whether it originates from the config sync plugin.
If so I might have to make another change to resolve this :slight_smile:


I am not 100% sure about this, but the other issue we discussed could be the root cause of this problem. Since I changed the configuration as mentioned in the other issue, there were no images lost so far.

So I think it was because of the wrongly configured API Upload directory. I have no idea how to reproduce the error on my machines, which is why I am not yet 100% sure if it is solved :smiley:

I think this is solved now. The config-sync plugin was the problem, and this was the fix for this. Then the upload folder is not overwritten on restarts, and everything works fine again :+1: