Strapi v4 not detecting cloudinary upload provider

System Information
  • Strapi Version: v4.0.0
  • Operating System: Mac OS X
  • Database: SQL Lite
  • Node Version: v14.15.0
  • NPM Version: 6.14.8
  • Yarn Version: v1.22.17

I have started a new project using Strapi v4.0.0.
Installed “@strapi/provider-upload-cloudinary”: “^4.0.0” Cloudinary upload provider.

Created a plugins.js file at ./config/plugins.js with the below content to enable the provider.

module.exports = ({ env }) => ({
  // ...
  upload: {
    provider: 'cloudinary',
    providerOptions: {
      cloud_name: env('CLOUDINARY_NAME'),
      api_key: env('CLOUDINARY_KEY'),
      api_secret: env('CLOUDINARY_SECRET'),
    actionOptions: {
      upload: {},
      delete: {},
  // ...

After accessing the admin UI, as I try to upload the files. Files are getting uploaded into ./public/uploads/ folder rather than uploading to Cloudinary storage service.

I have tried passing env variables like example: CLOUDINARY_NAME=xxxxxxxxx yarn run develop
Also tried with using .env file.

Please let me know if I am missing any config. Unable to fix this issue for the past 2 days :pensive:.

1 Like

It has changed the structure notice the enable plugin part

Still not working :confused: or can you explain what we must do exactly?

I’ve the same issue with strapi v4.
Did anyone succeed to upload images to cloudinary via strapi v4?

@sssch-99 Found the solution on GitHub, config is slightly different

As I mentioned on github with that configuration you can upload the files to cloudinary. But I still don’t know why the preview is not showing in strapi.

Captura realizada el 2021-12-06 09.27.01

1 Like

Have a look at:

I don’t know why am I having this error! I cannot get assest to upload image to cloudinary. Please let me know some suggests