Unable to customize the admin panel

System Information
  • Strapi Version: 4.0.0
  • Operating System: macOS 11.4
  • Database: SQLite
  • Node Version: 16.13.0
  • NPM Version: 8.1…0
  • Yarn Version: /

I am trying to create a custom Strapi admin panel. In order to do so I am following the steps documented in the Strapi docs: Documentation.

I update my app.js file located inside the /src/admin folder. I use the "Example of a custom configuration for the admin panel’ from the documentation and do some small alterations (see at the bottom of this question).

But when I reload the admin panel then nothing has changed. I can still only choose French and English as the language and the colors stay the same. Even tough I have added German as a language and have changed the colors.

In order to deploy the server I use the ‘npm run develop’ command. I have tried to use the ‘strapi develop’ command but then I get the following error: “You need to run strapi develop in a Strapi project. Make sure you are in the right directory”. Even tough I am inside the main folder of the project “my-app/”.

export default {
  config: {
    // Replace the Strapi logo in auth (login) views
    auth: {
    // Replace the favicon
    head: {
    // Add a new locale, other than 'en'
    locales: ['fr', 'de'],
    // Replace the Strapi logo in the main navigation
    menu: {
    // Override or extend the theme
    theme: {
      colors: {
        alternative100: '#f6ecfc',
        alternative200: '#e0c1f4',
        alternative500: '#ac73e6',
        alternative600: '#9736e8',
        alternative700: '#8312d1',
        danger700: '#b72b1a'
    // Extend the translations
    translations: {
      fr: {
        'Auth.form.email.label': 'test',
        Users: 'Utilisateurs',
        City: 'CITY (FRENCH)',
        // Customize the label of the Content Manager table.
        Id: 'ID french',
    // Disable video tutorials
    tutorials: false,
    // Disable notifications about new Strapi releases
    notifications: { release: false },

  bootstrap() { },

Same here, not working for me either. I’ve placed the same configuration into /src/admin/app.js under the config object. removed cached, rebuilded the admin with
npm run build, but it keeps ignoring the changes.

did you found a solution ?

Have you tried running the develop comand with the --watch-admin flag?

strapi develop --watch-admin

I have same issue, after i found that app.js name in my code folder is wrong, it just app…js

I fix it

Everythis is work

1 Like

Hi People,

Does someone get the information about it?

The Strapi is great, but the documentation is really poor and buggy.

I believe that anyone using Strapi the step number 0 would customize the Admin …

When I tried to name the app.js like this I lost the entire customization for me, what I am missing is regarding the theme, seems that it does not works

You have to re-build the admin for the changes to show up. So run npm/yarn build, then npm/yarn develop. Then you should see your updates.

Maybe you need to go to each project folder and run yarn install and yarn build. In my case, this solved it.

1 Like

thanks, solved my problem.

As all the steps are right, but It is not appearing because of cache saved just,

Delete the .cache folder and RUN

npm run build
npm run develop

It will rebuild again


I had the same error and I solved it by changing the path to call ‘customisations’ within .strapi/client/app.js

wrong: …/…/admin/app.js
correct: …/…/src/admin/app.js

Now everything works perfectly :slight_smile: