“Unsupported engine app@0.1.0” when installing Strapi

System Information
  • Strapi Version: 4.16.2
  • Operating System: Red Hat
  • Node Version: v18.10.0
  • NPM Version: 8.19.2

I recently updated the Strapi version from v4.14.6 to v4.16.2 and saw that this new version requires node >= 18 (from v4.15.0). When running “npm install”, I get no errors, but the following warning:

npm WARN EBADENGINE Unsupported engine {
npm WARN EBADENGINE   package: 'app@0.1.0',
npm WARN EBADENGINE   required: { node: '>=12.x.x <=16.x.x', npm: '>=6.0.0' },
npm WARN EBADENGINE   current: { node: 'v18.10.0', npm: '8.19.2' }

When I run Strapi with npm run develop, everything works.

Can I ignore this warning now or
can I correct it or
will it be corrected by the Strapi dev team?

Best regards.


  • delete node_modules directory
  • delete package-lock.json
  • npm i
  • npm run build