While adding text in rich text editor the inverted comma are changed to some chinese letter. When sending data to payload it is correct but while saving this issue occurs

this error does not occurs if data is inserted manually but if the data is copied from any source and paste it inside the editor then saved this issue happens.

After saving

My Strapi version and all other installed dependencies are:

"@ckeditor/strapi-plugin-ckeditor": "^0.0.7",
    "@sendgrid/mail": "^7.7.0",
    "@strapi/plugin-users-permissions": "4.4.5",
    "@strapi/strapi": "4.4.5",
    "@strapi/utils": "^4.5.5",
    "better-sqlite3": "7.4.6",
    "body-parser": "^1.20.1",
    "nodemailer": "^6.9.1",
    "pg": "^8.8.0",
    "react": "^17.0.2",
    "strapi-plugin-import-export-entries": "^1.18.0"

I’m not a CKEditor user but have worked extensively with TinyMCE (I worked at Tiny previously). I’m making a 99.9% assumption here as with my experience on TinyMCE.

The issue is how CKEditor interprets the data it receives through your clipboard when pasting. You may think it’s easy to solve but I can tell you it takes a significant amount of hours to perfect copy & paste, especially from Microsoft Word.

To confirm, after you paste the content into the editor, can you ‘view source’ to see the HTML CKEditor has created?

Ck editor has interpreted rightly, While pasting in editor and while saving data the network payload has right data but when the response comes it changes to some chinese letters.

Can you please try converting the content to UTF-8 before pasting it into the CKEditor?


  • VSCode (Look for encoding at the bottom of the window → click it and a popup opens → select UTF-8 and click save with encoding.)
  • Notepad++ (Menu → Encoding → Convert to UTF-8-BOM)

It still converts to chinese I have tried both ways . Is there any other alternative?

Are you able to please provide an example file with the problematic content inside?

Additionally, I’ve noticed in your screenshot above that it appears to be problematic with apostrophes. Try updating those apostrophes to UTF-8 safe apostrophes. You may need to delete the current value and manually replace the ’ (apostrophe).

Also what database are you using?

I am using postgresql