WYSIWYG field stopped working after upgrade

while being on Strapi 3.1.5, I followed the guide in the docs (Creating a new Field in the administration panel) to use CKEditor, everything worked flawlessly and the client was happy. Recently I upgraded/migrated to Strapi 3.6.9, and since then the editor field is not loading content that is already in the database. I can create new content in that field, save it, and it can be accessed through the API. When I try to change the content in an existing piece of content, the editor UI displays just fine but does not load the content of the field.
Any ideas what went wrong here?
Thanks a lot,

1 Like

…or maybe anyone has any pointers on how I can try and debug this myself?

did you check if there might a suitable migration guide (link) for wysiwyg fields? could be that something changed between 3.1.5 and 3.6.9.

thank you for the suggestion. In fact I followed all migration guides when updating from 3.1.5 to 3.6.9, however it unfortunately did not contain anything about the WYSIWYG field.

I solved it by removing the code from the docs and installed the plugin https://github.com/Roslovets-Inc/strapi-plugin-ckeditor5.
Then I customized that using the customizations (toolbar customizations and custom styles) I had added to the code before.
I also had to apply this fix https://github.com/Roslovets-Inc/strapi-plugin-ckeditor5/issues/12#issuecomment-915618516 to make the media library button work.
Now it’s working fine.