Yarn Install Strapi v4 not working

  • “strapi”: “3.6.8”
  • “sqlite3”: “5.0.0”
  • “node”: “>=10.16.0 <=14.x.x”
  • “npm”: “^6.0.0”
  • Yarn Version: 1.22.17

Hi, when I try to upgrade from Strapi version 3.6.8 to 4.0.0 and change all Strapi packages, when I run yarn install it returns the following screen:
Captura de pantalla 2021-12-14 a las 10.31.48

It seems as if the package for version 4 doesn’t exist in yarn. Can someone help me please?
These are all the dependencies that you should update:
“dependencies”: {
“strapi”: “3.6.8”,
“strapi-admin”: “3.6.8”,
“strapi-utils”: “3.6.8”,
“strapi-plugin-content-type-builder”: “3.6.8”,
“strapi-plugin-content-manager”: “3.6.8”,
“strapi-plugin-users-permissions”: “3.6.8”,
“strapi-plugin-email”: “3.6.8”,
“strapi-plugin-upload”: “3.6.8”,
“strapi-plugin-i18n”: “3.6.8”,
“strapi-connector-bookshelf”: “3.6.8”


Facing the same issue. No resolution yet.

1 Like

I seems like you’re using the wrong packages. The v4 packages start with: @strapi/. e.g. @strapi/strapi. I hope this helps.
see https://yarnpkg.com/package/@strapi/strapi

Were you able to upgrade from v3.6 to v4?

@shrikant - We have completed about 95% of the migration. The rest is ongoing (fixing table names, etc). We are using the utility scripts here:

which have recently been updated.

Thank you for the update! I’ll try using the scripts! Appreciate your response and contribution!