Importing, Exporting & Transferring Data with Strapi CLI

As a developer working with Strapi in the past, there have been many scenarios where I wished I could have easily taken a backup of my data. To export my data from one Strapi instance and then import it back to another Strapi instance when needed was a frequent chore. Thanks to the Strapi CLI, this is now a trivial task.

This is a companion discussion topic for the original entry at
1 Like

Nice article! It would be great to use this feature, but for me and others, it doesn’t work. I hope someone at Strapi can take a look or suggest how we can further debug the problem.


I am also having the same issue. I am able to push from my local environment to the production environment. But pulling from production to local does not work (stuck). I have also tried pushing from production to local, the transfer process went through, however, all the tables are empty. Exporting from production and importing at local gives me the same result. Anyone knows how to fix this?

I would update to the most recent Strapi version and try again. We have added few fixes and on Wednesday we will be releasing another fix for transfer pull.

Let me know if you still have issues after updating.

Also, quick question, are you using local image provider that stores the files locally or are you using an image provider like amazon s3 or cloudinery…

I updated Strapi to the latest (v4.10.5) but transfer pull (pulling from production to local) is still stuck. For transfer push (pushing from production), the process does not stuck but my local environment still has all collections empty. Same for exporting/importing.

I am not using any image provider at all.

Nice article but the devs should make sure the feature works first (it might have worked before, but since 2nd half of April it clearly does not.

See the thread here:

Why is it taking so long to fix devs!?

Good news for me. I updated from 4.9.2 to 4.10.6 for both the local and remote environments and now the data transfer is initiated. Now I have another problem the operation is stuck at assets transfer, but I will investigate this new issue.