Strapi and heroku issue

Hi coders,

I was following steps for strapi deployment to heroku with POSTGRESQL. My project was based on localhost before deploying. After that i got a link to herokuapp and opening resulted in strapi production page, then I added */admin and got redirected to registration(i had account already, since this was project i worked on already on localhost). After registration i got something like ‘internal error’, tried to recover password, but several times the link with recovery was sent to email, but didn’t work at all.
If I try something like i get message : {“statusCode”:403,“error”:“Forbidden”,“message”:“Forbidden”}

Something i might be missing here?

Your local database’s data is not pushed into Heroku, assuming you created Strapi with --quickstart that creates a SQLite (single-file based data storage) and in Heroku you would be using PostgreSQL (SQLite will not work on Heroku).

We do not currently provide tooling to sync the data over to the PG database from SQLite, see the following FAQ: Troubleshooting - Strapi Developer Documentation

Local modification should only be for testing purposes during code modification, in a case like yours all content will need to be created on the “production” Heroku instance

1 Like

Thank you for your time and answer! But still, why I’m not able to that newly created project? I get info to my email, but the link is not working for password recovery.

Is this for admins or users?

It was for admins, but I went mongoDB way and now everything works perfect. Thank you for really fast response!