Unable to create content after deploy to Heroku

System Information
  • Strapi Version: 3.4.1
  • Operating System: Linux
  • Database: PostgreSQL
  • Node Version: 14.15.1
  • NPM Version: 6.14.8

Hello,

For my portfolio, I created a local backend with Strapi. I created collections and added content. I retrieve data via the REST API on a React based frontend. Everything works well locally.
To make my portfolio public, I decided to deploy my Strapi app on Heroku. I followed the official tutorial and it seemed to work since I was able to access the administration interface. My collections and single types were there. At first I was surprised to see that all the data already created had disappeared, but I understood that this was normal according to this topic. So I have to recreate the data, I guess.
Problem: On the admin panel, I no longer have the possibility to create content! I do have access to the Content Type Builder and the Media Library but I don’t have any tabs to create my content.

Maybe the deployment didn’t go well? Or maybe I’m completely missing something?

Thank you in advance and have a nice day.

Can you share a screenshot from your admin?
Inside any content-type and in content type builder.

In Strapi we are not allowed to create new collection types or components in production environment.
Way to go: check your env variables, change it to development, start your strapi project locally, save and commit changes and push to heroku once you are done.

Thank you for your answer.
Here is a screenshot of my admin. As you can see, I don’t have any tabs concerning content-types or collections, although I have created some in development.

Thank you for your answer.
I understand that. But the problem is elsewhere: I did create collections and content-types in development but once Strapi is in production mode, I don’t have the possibility to create content based on these collections or content-types.

Oh, sorry for misunderstanding. I had this problem too and chose to create a fresh strapi project from zero.

No problem. Okay, i’ll try again in a fresh install. Did you use the —quickstart command or not ?

I solved my problem by creating a new strapi project, this time using a PostgreSQL database. To do this, do not use the “–quickstart” flag when creating the project. This way, as indicated in the documentation here, you will be able to choose which type of database you want to use.

There seems to be a problem between PaaS systems and SQLite databases, related to this issue.

I think it should be more clearly indicated in the Strapi documentation that it is recommended not to use SQLite databases if you plan to deploy on PaaS systems.

1 Like