Strapi don't starts

I recently installed via yarn and via docker according to official documentation, in linux without errors however when running yarn develop it compiles the project but n start the server below follows docker log:
strapi_1 | Starting your app…
strapi_1 | Building your admin UI with development configuration…
strapi_1 | :information_source: Compiling Webpack
strapi_1 | :heavy_check_mark: Webpack: Compiled successfully in 1.09m
re-advanced-api_strapi_1 exited with code 0
with docker with yarn simply for execution

I need more information to understand the cause.

What information do you need?
I use it on linux mint
but automatic installation doesn’t work either

Anything you can provide, give me any information about your system, specs, versions of stuff, ect

This is the rough idea of stuff we ask for from Enterprise users, the same information could be useful for the community users as well: What debugging information do we need to assist you? : Support Portal

Linux mint-rafaelejosi 5.4.0-81-generic #91-Ubuntu SMP Thu Jul 15 19:09:17 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
Strapi 3.6.8
PostgreSQL 12.8 (Ubuntu 12.8-0ubuntu0.20.04.1)
Node 14.17.6
Npm 6.14.15

What if you try without using docker?

I’ve already tried using yarn and npx also “the error is the same”
yarn run v1.22.11
$ strapi develop
Done in 5.31s.
The only thing I didn’t try was the global install.

I’m sorry with the information you’ve provided I have no idea. I too am a Linux Mint user and can’t reproduce the issues you are having.

the strapi start has an error output does it mean something?

$ strapi start
Illegal instruction (core dumped)
error Command failed with exit code 132.
info Visit for documentation about this command.```

That error usually means you have installed node_modules for a different system then you are trying to run it on (some modules get built for a specific architecture).

Try deleting the node_modules and package-lock.json/yarn.lock and reinstalling them

see: express - Illegal instruction (core dumped) Node.Js - Stack Overflow

with this command “works” yarn develop --watch-admin
Open the browser, but it keeps loading forever

I’d suggest not starting with that command and just try to get it running normally. The --watch-admin flag is specifically for developing custom code and modifications to the Strapi Admin panel

procedure done, but problem still persists.

Honestly at this point I’d be willing to bet you have something wrong with your system. I have no idea what, but there is clearly something abnormal about your host system.

It’s a shame I would love to use your cms

there is no way to debug? Generate a report since there are no apparent errors?

I will do the test on a virtual machine

done the test still doesn’t work

I had a similar issue when using docker.
How does your dockerfile look etc? Also, are you binding the node_modules etc to the container by any chance?

I ended up do a minor tweak to mine not to get the issue we are talking about, where it crashed due that it had node modules from the host system and a different in the container etc.

What version of yarn are you using ? :slight_smile:

version: '3'
    image: strapi/strapi
      DATABASE_CLIENT: postgres
      DATABASE_NAME: strapi
      DATABASE_HOST: postgres
      DATABASE_PORT: 5432
      - ./app:/srv/app
      - '1337:1337'
      - postgres

    image: postgres
      POSTGRES_DB: strapi
      POSTGRES_USER: strapi
      - ./data:/var/lib/postgresql/data